const regex = new RegExp('n\\'t|\\'(?:ll|[vr]e|[msd])', 'gm')
const str = `should've can't mustn't we'll`;
const subst = ` \g<0>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);