$re = '/n\'t|\'(?:ll|[vr]e|[msd])/m';
$str = 'should\'ve can\'t mustn\'t we\'ll';
$subst = " \g<0>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;