#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^K(?!.*#.*#)(?:#?[0-9a-z]){1,3}#?\$$"
Local $sString = "Kabc$" & @CRLF & _
"Ka#bc$" & @CRLF & _
"K01#a$" & @CRLF & _
"K#1ab$" & @CRLF & _
"Ka1a#$" & @CRLF & _
"" & @CRLF & _
"K#1a#$" & @CRLF & _
"Ka1ab$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Pattern starts with the letter K" & @CRLF & _
"Is followed by any number (0-9) or any letter (a-z) between 1 and 3 times." & @CRLF & _
"The symbol # can exist 0 or 1 time, anywhere after the starting K." & @CRLF & _
"The pattern must end with the symbol $."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")