const regex = /^K(?!.*#.*#)(?:#?[0-9a-z]){1,3}#?\$$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^K(?!.*#.*#)(?:#?[0-9a-z]){1,3}#?\\$$', 'gm')
const str = `Kabc\$
Ka#bc\$
K01#a\$
K#1ab\$
Ka1a#\$
K#1a#\$
Ka1ab\$
Pattern starts with the letter K
Is followed by any number (0-9) or any letter (a-z) between 1 and 3 times.
The symbol # can exist 0 or 1 time, anywhere after the starting K.
The pattern must end with the symbol \$.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}