# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^K(?!.*#.*#)(?:#?[0-9a-z]){1,3}#?\$$"
test_str = ("Kabc$\n"
"Ka#bc$\n"
"K01#a$\n"
"K#1ab$\n"
"Ka1a#$\n\n"
"K#1a#$\n"
"Ka1ab$\n\n\n"
"Pattern starts with the letter K\n"
"Is followed by any number (0-9) or any letter (a-z) between 1 and 3 times.\n"
"The symbol # can exist 0 or 1 time, anywhere after the starting K.\n"
"The pattern must end with the symbol $.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.