import Foundation
let pattern = ##"^K(?!.*#.*#)(?:#?[0-9a-z]){1,3}#?\$$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Kabc$
Ka#bc$
K01#a$
K#1ab$
Ka1a#$
K#1a#$
Ka1ab$
Pattern starts with the letter K
Is followed by any number (0-9) or any letter (a-z) between 1 and 3 times.
The symbol # can exist 0 or 1 time, anywhere after the starting K.
The pattern must end with the symbol $.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)