use strict;
my $str = 'Kabc$
Ka#bc$
K01#a$
K#1ab$
Ka1a#$
K#1a#$
Ka1ab$
Pattern starts with the letter K
Is followed by any number (0-9) or any letter (a-z) between 1 and 3 times.
The symbol # can exist 0 or 1 time, anywhere after the starting K.
The pattern must end with the symbol $.';
my $regex = qr/^K(?!.*#.*#)(?:#?[0-9a-z]){1,3}#?\$$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}