import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^K(?!.*#.*#)(?:#?[0-9a-z]){1,3}#?\\$$";
final String string = "Kabc$\n"
+ "Ka#bc$\n"
+ "K01#a$\n"
+ "K#1ab$\n"
+ "Ka1a#$\n\n"
+ "K#1a#$\n"
+ "Ka1ab$\n\n\n"
+ "Pattern starts with the letter K\n"
+ "Is followed by any number (0-9) or any letter (a-z) between 1 and 3 times.\n"
+ "The symbol # can exist 0 or 1 time, anywhere after the starting K.\n"
+ "The pattern must end with the symbol $.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}