import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "RunObjectType=Page;(\\s+)RunObjectID=70000";
final String string = " RunObjectType=Page;\n"
+ " RunObjectID=70000;";
final String subst = "RunObjectType=Page;$1RunObjectID=88888;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}