// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"RunObjectType=Page;(\s+)RunObjectID=70000").unwrap();
let string = " RunObjectType=Page;
RunObjectID=70000;";
let substitution = "RunObjectType=Page;$1RunObjectID=88888;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}