use strict;
my $str = ' RunObjectType=Page;
RunObjectID=70000;';
my $regex = qr/RunObjectType=Page;(\s+)RunObjectID=70000/p;
my $subst = 'RunObjectType=Page;$1RunObjectID=88888;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";