re = /RunObjectType=Page;(\s+)RunObjectID=70000/
str = ' RunObjectType=Page;
RunObjectID=70000;'
subst = 'RunObjectType=Page;$1RunObjectID=88888;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result