const regex = /RunObjectType=Page;(\s+)RunObjectID=70000/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('RunObjectType=Page;(\\s+)RunObjectID=70000', 'g')
const str = ` RunObjectType=Page;
RunObjectID=70000;`;
const subst = `RunObjectType=Page;$1RunObjectID=88888;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);