#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z|.-_]*@[a-zA-Z]*.[a-zA-Z]{2,}"
Local $sString = "test@gmail.com" & @CRLF & _
"test@Gmail.com" & @CRLF & _
"nikolо@gmail.com" & @CRLF & _
"test_best.Petrovi4@gmail.com" & @CRLF & _
"testUser@gmail.com" & @CRLF & _
"Николай@rambler.ru" & @CRLF & _
"!thebest.@rambler.ru " & @CRLF & _
"!thebest.@rambler.u "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")