package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z|.-_]*@[a-zA-Z]*.[a-zA-Z]{2,}`)
var str = `test@gmail.com
test@Gmail.com
nikolо@gmail.com
test_best.Petrovi4@gmail.com
testUser@gmail.com
Николай@rambler.ru
!thebest.@rambler.ru
!thebest.@rambler.u `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}