re = /[a-zA-Z|.-_]*@[a-zA-Z]*.[a-zA-Z]{2,}/
str = 'test@gmail.com
test@Gmail.com
nikolо@gmail.com
test_best.Petrovi4@gmail.com
testUser@gmail.com
Николай@rambler.ru
!thebest.@rambler.ru
!thebest.@rambler.u '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end