import re
regex = re.compile(r"[a-zA-Z|.-_]*@[a-zA-Z]*.[a-zA-Z]{2,}")
test_str = ("test@gmail.com\n"
"test@Gmail.com\n"
"nikolо@gmail.com\n"
"test_best.Petrovi4@gmail.com\n"
"testUser@gmail.com\n"
"Николай@rambler.ru\n"
"!thebest.@rambler.ru \n"
"!thebest.@rambler.u ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")