$re = '/[a-zA-Z|.-_]*@[a-zA-Z]*.[a-zA-Z]{2,}/';
$str = 'test@gmail.com
test@Gmail.com
nikolо@gmail.com
test_best.Petrovi4@gmail.com
testUser@gmail.com
Николай@rambler.ru
!thebest.@rambler.ru
!thebest.@rambler.u ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);