// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z|.-_]*@[a-zA-Z]*.[a-zA-Z]{2,}").unwrap();
let string = "test@gmail.com
test@Gmail.com
nikolо@gmail.com
test_best.Petrovi4@gmail.com
testUser@gmail.com
Николай@rambler.ru
!thebest.@rambler.ru
!thebest.@rambler.u ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}