import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z|.-_]*@[a-zA-Z]*.[a-zA-Z]{2,}";
final String string = "test@gmail.com\n"
+ "test@Gmail.com\n"
+ "nikolо@gmail.com\n"
+ "test_best.Petrovi4@gmail.com\n"
+ "testUser@gmail.com\n"
+ "Николай@rambler.ru\n"
+ "!thebest.@rambler.ru \n"
+ "!thebest.@rambler.u ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}