#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b0\d"
Local $sString = "# bad" & @CRLF & _
"FOO=01" & @CRLF & _
"FOO=1,02,3" & @CRLF & _
"FOO=[1,02,3]" & @CRLF & _
"" & @CRLF & _
"# good" & @CRLF & _
"FOO=1" & @CRLF & _
"FOO=[0,1,0,2,0,3]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")