import re
regex = re.compile(r"\b0\d", flags=re.MULTILINE)
test_str = ("# bad\n"
"FOO=01\n"
"FOO=1,02,3\n"
"FOO=[1,02,3]\n\n"
"# good\n"
"FOO=1\n"
"FOO=[0,1,0,2,0,3]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")