// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b0\d").unwrap();
let string = "# bad
FOO=01
FOO=1,02,3
FOO=[1,02,3]
# good
FOO=1
FOO=[0,1,0,2,0,3]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}