import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0\\d";
final String string = "# bad\n"
+ "FOO=01\n"
+ "FOO=1,02,3\n"
+ "FOO=[1,02,3]\n\n"
+ "# good\n"
+ "FOO=1\n"
+ "FOO=[0,1,0,2,0,3]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}