package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b0\d`)
var str = `# bad
FOO=01
FOO=1,02,3
FOO=[1,02,3]
# good
FOO=1
FOO=[0,1,0,2,0,3]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}