$re = '/\b0\d/m';
$str = '# bad
FOO=01
FOO=1,02,3
FOO=[1,02,3]
# good
FOO=1
FOO=[0,1,0,2,0,3]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);