using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://(\S+\.)+\S+(/\S+)*/?";
string input = @"https://t.co/8OMryrUVET
https://regex101.com/
https://www.google.com/search?client=firefox-b-d&q=nltk+string+cleaning
https://machinelearningmastery.com/clean-text-machine-learning-python/
py New Year from #MarALago! Thank you to my...
4 Well the year has officially begun. I have man...
5 I will be going to Mississippi tomorrow night ...
6 The person that Hillary Clinton least wants to...
7 Thank you so much to https://t.co/8OMryrUVET f...
8 #VoteTrump2016 & together we will #MakeAmerica...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}