import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(\\S+\\.)+\\S+(/\\S+)*/?";
final String string = "https://t.co/8OMryrUVET\n"
+ "https://regex101.com/\n"
+ "https://www.google.com/search?client=firefox-b-d&q=nltk+string+cleaning\n"
+ "https://machinelearningmastery.com/clean-text-machine-learning-python/\n\n"
+ "py New Year from #MarALago! Thank you to my...\n"
+ "4 Well the year has officially begun. I have man...\n"
+ "5 I will be going to Mississippi tomorrow night ...\n"
+ "6 The person that Hillary Clinton least wants to...\n"
+ "7 Thank you so much to https://t.co/8OMryrUVET f...\n"
+ "8 #VoteTrump2016 & together we will #MakeAmerica...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}