$re = '/https?://(\S+\.)+\S+(/\S+)*/?/m';
$str = 'https://t.co/8OMryrUVET
https://regex101.com/
https://www.google.com/search?client=firefox-b-d&q=nltk+string+cleaning
https://machinelearningmastery.com/clean-text-machine-learning-python/
py New Year from #MarALago! Thank you to my...
4 Well the year has officially begun. I have man...
5 I will be going to Mississippi tomorrow night ...
6 The person that Hillary Clinton least wants to...
7 Thank you so much to https://t.co/8OMryrUVET f...
8 #VoteTrump2016 & together we will #MakeAmerica...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);