import re
regex = re.compile(r"https?://(\S+\.)+\S+(/\S+)*/?", flags=re.MULTILINE)
test_str = ("https://t.co/8OMryrUVET\n"
"https://regex101.com/\n"
"https://www.google.com/search?client=firefox-b-d&q=nltk+string+cleaning\n"
"https://machinelearningmastery.com/clean-text-machine-learning-python/\n\n"
"py New Year from #MarALago! Thank you to my...\n"
"4 Well the year has officially begun. I have man...\n"
"5 I will be going to Mississippi tomorrow night ...\n"
"6 The person that Hillary Clinton least wants to...\n"
"7 Thank you so much to https://t.co/8OMryrUVET f...\n"
"8 #VoteTrump2016 & together we will #MakeAmerica...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")