import Foundation
let pattern = #"https?://(\S+\.)+\S+(/\S+)*/?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://t.co/8OMryrUVET
https://regex101.com/
https://www.google.com/search?client=firefox-b-d&q=nltk+string+cleaning
https://machinelearningmastery.com/clean-text-machine-learning-python/
py New Year from #MarALago! Thank you to my...
4 Well the year has officially begun. I have man...
5 I will be going to Mississippi tomorrow night ...
6 The person that Hillary Clinton least wants to...
7 Thank you so much to https://t.co/8OMryrUVET f...
8 #VoteTrump2016 & together we will #MakeAmerica...
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)