#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Paycheck_Box_EMP_(\d+).*"
Local $sString = "Paycheck_Box_EMP_61299_451" & @CRLF & _
"Paycheck_Box_EMP_5512_221" & @CRLF & _
"Paycheck_Box_EMP_99993_881" & @CRLF & _
"Paycheck_Box_EMP_831_141"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")