// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Paycheck_Box_EMP_(\d+).*").unwrap();
let string = "Paycheck_Box_EMP_61299_451
Paycheck_Box_EMP_5512_221
Paycheck_Box_EMP_99993_881
Paycheck_Box_EMP_831_141";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}