import re
regex = re.compile(r"Paycheck_Box_EMP_(\d+).*", flags=re.MULTILINE)
test_str = ("Paycheck_Box_EMP_61299_451\n"
"Paycheck_Box_EMP_5512_221\n"
"Paycheck_Box_EMP_99993_881\n"
"Paycheck_Box_EMP_831_141")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")