const regex = /Paycheck_Box_EMP_(\d+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Paycheck_Box_EMP_(\\d+).*', 'gm')
const str = `Paycheck_Box_EMP_61299_451
Paycheck_Box_EMP_5512_221
Paycheck_Box_EMP_99993_881
Paycheck_Box_EMP_831_141`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}