using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Paycheck_Box_EMP_(\d+).*";
string input = @"Paycheck_Box_EMP_61299_451
Paycheck_Box_EMP_5512_221
Paycheck_Box_EMP_99993_881
Paycheck_Box_EMP_831_141";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}