use strict;
my $str = 'Paycheck_Box_EMP_61299_451
Paycheck_Box_EMP_5512_221
Paycheck_Box_EMP_99993_881
Paycheck_Box_EMP_831_141';
my $regex = qr/Paycheck_Box_EMP_(\d+).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}