# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\!\[.+?\]\((.+?)\)/<img src="$1" width="300">/gm;t' <<< "
"