$re = '/\!\[.+?\]\((.+?)\)/m';
$str = '
';
$subst = "<img src=\"$1\" width=\"300\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;