package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\!\[.+?\]\((.+?)\)`)
var str = `
`
var substitution = "<img src="$1" width="300">"
fmt.Println(re.ReplaceAllString(str, substitution))
}