using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<[^\s].*?>\n?.*\n?<\/.*?>|<[^\s].*?[^\s]["" ]{0,1}\/>)";
string substitution = @"{{1}}";
string input = @"Hi :wave:,
this is html in like <div> HTML tag </div>
and this below hypertext is span with tags
<div>
text <b><i></i></b>
</div>
<script>
console.log('hi');
</script>
<span id=""text""> Hi <b>you</b> </span>
<id></id>
<br />
<br />
<br/>
<img src=""./here.jpg"" />
<input text=""text""/>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}