const regex = /(?:<[^\s].*?>\n?.*\n?<\/.*?>|<[^\s].*?[^\s][" ]{0,1}\/>)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<[^\\s].*?>\\n?.*\\n?<\\\/.*?>|<[^\\s].*?[^\\s][" ]{0,1}\\\/>)', 'gmi')
const str = `Hi :wave:,
this is html in like <div> HTML tag </div>
and this below hypertext is span with tags
<div>
text <b><i></i></b>
</div>
<script>
console.log('hi');
</script>
<span id="text"> Hi <b>you</b> </span>
<id></id>
<br />
<br />
<br/>
<img src="./here.jpg" />
<input text="text"/>`;
const subst = `{{1}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);