// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(?:<[^\s].*?>\n?.*\n?<\/.*?>|<[^\s].*?[^\s][" ]{0,1}\/>)"#).unwrap();
let string = "Hi :wave:,
this is html in like <div> HTML tag </div>
and this below hypertext is span with tags
<div>
text <b><i></i></b>
</div>
<script>
console.log('hi');
</script>
<span id=\"text\"> Hi <b>you</b> </span>
<id></id>
<br />
<br />
<br/>
<img src=\"./here.jpg\" />
<input text=\"text\"/>";
let substitution = "{{1}}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}