import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<[^\\s].*?>\\n?.*\\n?<\\/.*?>|<[^\\s].*?[^\\s][\" ]{0,1}\\/>)";
final String string = "Hi :wave:,\n"
+ "this is html in like <div> HTML tag </div>\n"
+ "and this below hypertext is span with tags\n"
+ "<div>\n"
+ "text <b><i></i></b>\n"
+ "</div>\n"
+ "<script>\n"
+ " console.log('hi');\n"
+ "</script>\n\n"
+ "<span id=\"text\"> Hi <b>you</b> </span>\n"
+ "<id></id>\n"
+ "<br />\n"
+ "<br />\n"
+ "<br/>\n"
+ "<img src=\"./here.jpg\" />\n"
+ "<input text=\"text\"/>";
final String subst = "{{1}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}