import re
regex = re.compile(r"(?:<[^\s].*?>\n?.*\n?<\/.*?>|<[^\s].*?[^\s][\" ]{0,1}\/>)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Hi :wave:,\n"
"this is html in like <div> HTML tag </div>\n"
"and this below hypertext is span with tags\n"
"<div>\n"
"text <b><i></i></b>\n"
"</div>\n"
"<script>\n"
" console.log('hi');\n"
"</script>\n\n"
"<span id=\"text\"> Hi <b>you</b> </span>\n"
"<id></id>\n"
"<br />\n"
"<br />\n"
"<br/>\n"
"<img src=\"./here.jpg\" />\n"
"<input text=\"text\"/>")
subst = "{{1}}"
result = regex.sub(subst, test_str)
if result:
print(result)