# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(([^(]+)\)/[\1]/gm;t' <<< "[('1','Hello is 1)people 2)animals'), ('People are 1) hello 2) animals'), ('a')]"