use strict;
my $str = '[(\'1\',\'Hello is 1)people 2)animals\'), (\'People are 1) hello 2) animals\'), (\'a\')]';
my $regex = qr/\(([^(]+)\)/mp;
my $subst = '[\\1]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";