package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([^(]+)\)`)
var str = `[('1','Hello is 1)people 2)animals'), ('People are 1) hello 2) animals'), ('a')]`
var substitution = "[\1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}