import Foundation
let pattern = #"\(([^(]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[('1','Hello is 1)people 2)animals'), ('People are 1) hello 2) animals'), ('a')]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)