#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\(([^(]+)\)"
Local $sString = "[('1','Hello is 1)people 2)animals'), ('People are 1) hello 2) animals'), ('a')]"
Local $sSubst = "[\1]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)